代码之家  ›  专栏  ›  技术社区  ›  Alexander

NGINX+HTTPS导致外部请求的504网关超时错误

  •  0
  • Alexander  · 技术社区  · 8 年前

    我在我的Raspberry Pi上运行nginx服务器,使用HTTP协议似乎工作得很好。 最近,我决定在我的服务器上添加HTTPS支持,并从Let’s Encrypt获得了证书。 如果您从本地网络发送请求,它仍然像一个魅力。但通过HTTPS的每个外部请求都以504网关超时错误结束。

    这是我的配置:

    server {
        listen 80 default_server;
        listen [::]:80 default_server;
        listen 443 ssl default_server;
        listen [::]:443 ssl default_server;
    
        root /var/www/html;
    
        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html;
    
        server_name domain.name;
    
        ssl_session_cache shared:SSL:20m;
        ssl_session_timeout 180m;
    
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
    
        ssl_prefer_server_ciphers on;
        ssl_ciphers ECDH+AESGCM:ECDH+AES256:ECDH+AES128:DHE+AES128:!ADH:!AECDH:!MD5;
    
        ssl_certificate /etc/letsencrypt/live/domain.name/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/live/domain.name/privkey.pem;
        ssl_trusted_certificate /etc/letsencrypt/live/domain.name/chain.pem;
    
        location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/ =404;
        }
    
        location ~ /.well-known {
            allow all;
            root /usr/share/nginx/html;
        }
    }
    
    1 回复  |  直到 8 年前
        1
  •  -1
  •   Alexander    8 年前

    发现我的ISP默认有一个防火墙服务处于活动状态。它阻塞了与443端口的所有连接。禁用它解决了我的问题。