|
|
1
4
您的问题是选择了错误的群集密钥。从来没有人对按ID检索某个特定日志值感兴趣。如果您的系统与我见过的任何其他系统一样,那么所有查询都会要求:
我要假装我真的知道你的要求。您必须忘记关于存储的常识,在每个非聚集索引中实际复制所有数据。以下是我的建议:
您注意到我没有对您的查询脚本发表任何评论。这是因为在这个世界上,您无法做任何事情使查询在现有的表结构上运行得更快。 假装 我知道你的要求。但实际上我没有。我只是举了一个可能结构的例子。您真正应该做的是研究主题,并找出适合您需求的正确索引结构:
此外,谷歌的“覆盖索引”也会带来很多好文章。
|
|
|
2
1
我想到了几件事。
http://www.sql-server-performance.com/articles/per/derived_temp_tables_p1.aspx
http://www.sql-server-performance.com/tips/covering_indexes_p1.aspx 编辑
有关详细信息,请参阅此链接 http://technet.microsoft.com/en-us/library/cc966523.aspx 另外,请注意,我已经将这些项目编号为1,2,3,4,但是编辑器会自动重置它们 |
|
3
0
例如
|