代码之家  ›  专栏  ›  技术社区  ›  Zinx

ASP.NET3.5应用程序中的Crystal Reports Viewer

  •  2
  • Zinx  · 技术社区  · 16 年前

    我创建了一个ASP.NET3.5网站,里面有一个crystalreportviewer,如果我运行VisualStudio2008或在我自己的机器上运行,它工作得很好。但当我在web服务器上部署项目时,它开始给我错误信息。

    找不到CrystalDecision.web程序集 ,然后我在我的web服务器上安装了Crytal Runtime 2008。安装后,应用程序似乎正常,但当我用CrystalReportViewer打开页面时,它给了我不同的错误,如下所示:

    3 回复  |  直到 16 年前
        1
  •  1
  •   Community Mohan Dere    9 年前

    服务器和开发机器上的crystal程序集版本可能略有不同。比较两个版本的c:\windows\assembly中的版本号,看看是否有差异。如果存在,请更新服务器或更改web.config中程序集的版本号。

    而且 The located assembly's manifest definition does not match the assembly reference

        2
  •  1
  •   Zinx    16 年前

    花了将近2个小时后,我终于找到了解决办法。

    1. 从web服务器卸载Crystal Reports运行时。
    2. 检查web服务器是否仍有\program files\Business object文件夹,如果仍然存在,则将其删除。确保其他应用程序不依赖于它。

    3. 立即安装Crystal Report运行时。
    4. 重新启动IIS

    但是另一个问题出现了,crystal report viewer没有显示图标,原因是crystal report viewer查找 aspnet\u客户端\系统\u web\2\u 0\u 50727 文件夹位于网站的根文件夹中。在我的情况下,我的服务器上有多个网站,包括.NET 1.1、2.0和ASP,所以我有这个网站的wwwrootASP2.0文件夹。但默认情况下,web服务器是创建的 aspnet\u客户端\系统\u web\2\u 0\u 50727 默认网站(wwwroot)下的文件夹。所以,解决办法是,复制它 将文件夹放入网站的根目录中。答对 了现在很好用。

    我希望这会有帮助,

    干杯

        3
  •  0
  •   249076    16 年前

    我只是想补充一点,一种更简单的方法似乎是在web应用程序下创建一个名为aspnet\u client的虚拟目录,指向C:\Inetpub\wwwroot\aspnet\u client。

    这也会使crystal report viewer上的图像显示出来。它是在2003服务器上运行的IIS上使用visual studio 2008 crystal basic进行测试的。

    我读了之后就明白了 http://social.msdn.microsoft.com/Forums/en-US/vscrystalreports/thread/e2dc93b3-e594-4ae6-ba92-9440ccc7f6be

    推荐文章