|
0
|
| B''H Bi'ezras -- Boruch Hashem · 技术社区 · 6 年前 |
|
|
1
1
我之所以这么说,是因为我的职业生涯中花了大量时间来实现MTA,我觉得我应该警告您,这是一个解决了的问题,可以让您完全控制邮件流量,而且要编写一个能够大规模处理大量邮件的MTA,还需要解决一些非常棘手的问题。
你会感兴趣的第一版是在1982年左右发布的,名为RFC-821,又名IETF STD-10。后来经过多年的更新,它被更新为RFC-2821和一系列相关规范,但基本的RFC-821支持将为您提供您今天需要与99%的互联网主机交谈的内容。(这个数字会下降,因为您需要对TLS的ESMTP支持—但这并不难,也没有多大区别)。
显然这里还有更多的错误处理等——请阅读规范——但这是它的要点。这些数字是响应代码,具有特定的含义。行之间用\r\n分隔,宽度应小于1024字节。 <“一串资料”是一封电子邮件,不会有一行只是其中的一个点。如果电子邮件有这样一个点,另一端将发送一个额外的点。这在规格中。 最后,在$MAIL文件(可能是/var/MAIL/username或/var/spool/MAIL/username)中写入一堆东西,并将MUA指向它。松树,高山,榆树,或羊肉将是一个很好的MUA整理这些东西。 <XXXX>需要以From(无冒号)开头,以\n结尾。这是Berkeley mbox文件格式。它应该反映SMTP事务中的邮件发件人标头。 这种文件格式非常常见,大多数POP3和IMAP4服务器都支持这种格式。你也可以用Mozilla Thunderbird阅读。我知道当时Netscape Mail支持它。 |
|
|
ssast · EC2上OSM磁贴服务器的推荐规范 8 年前 |
|
|
user8040474 · 网络连接不工作 8 年前 |
|
|
J. Doe · C HTTP套接字过早关闭,并明显出现读取错误 8 年前 |
|
|
Aashishkebab · “连接被拒绝”或“没有此类文件或目录” 8 年前 |
|
|
Brown_MV · 从用户到注释的Sql插入 8 年前 |
|
|
Roei Edri · 错误的文件描述符错误[错误号9] 8 年前 |