代码之家  ›  专栏  ›  技术社区  ›  Priyank

Jboss启动错误

  •  1
  • Priyank  · 技术社区  · 16 年前

    在一个现有的应用程序上,我试图启动JBOSS服务器,我得到以下错误。

    不幸的是,到目前为止,我还不清楚这个jboss上配置了什么,正在使用什么。现在;我很快就想解决这个错误。

    如果查看堆栈跟踪,您可以建议缺少什么样的配置,或者我应该查看什么来修复此问题;那我会非常感激的。

    感谢您的帮助。

    ------------------在斯卡夫曼的帮助下;我能够将stacktrace还原为这个------------------

    07:36:36,971 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
    
    --- MBeans waiting for other MBeans ---
    ObjectName: xyz.management:service=Queue,name=managementQueue
      State: CONFIGURED
      I Depend On:
        jboss.messaging:service=ServerPeer
    
    ObjectName: xyz.management:service=Queue,name=indexQueue
      State: CONFIGURED
      I Depend On:
        jboss.messaging:service=ServerPeer
    
    ObjectName: xyz.management:service=Queue,name=adaptiveLearningQueue
      State: CONFIGURED
      I Depend On:
        jboss.messaging:service=ServerPeer
    
    ObjectName: xyz.management:service=Queue,name=xyzErrorQueue
      State: CONFIGURED
      I Depend On:
        jboss.messaging:service=ServerPeer
    
    --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
    ObjectName: jboss.messaging:service=ServerPeer
      State: NOTYETINSTALLED
      Depends On Me:
        xyz.management:service=Queue,name=managementQueue
        xyz.management:service=Queue,name=indexQueue
        xyz.management:service=Queue,name=adaptiveLearningQueue
        xyz.management:service=Queue,name=xyzErrorQueue
    
    
    javax.naming.NameNotFoundException: XAConnectionFactory not bound
        at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)
        at org.jnp.server.NamingServer.getBinding(NamingServer.java:537)
        at org.jnp.server.NamingServer.getObject(NamingServer.java:543)
        at org.jnp.server.NamingServer.lookup(NamingServer.java:296)
        at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:627)
        at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:589)
        at javax.naming.InitialContext.lookup(InitialContext.java:392)
        at org.jboss.ejb.plugins.jms.DLQHandler.createService(DLQHandler.java:182)
        at org.jboss.system.ServiceMBeanSupport.jbossInternalCreate(ServiceMBeanSupport.java:260)
        at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:188)
        at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContainerInvoker.java:665)
        at org.jboss.ejb.plugins.jms.JMSContainerInvoker$ExceptionListenerImpl$ExceptionListenerRunnable.run(JMSContainerInvoker.java:1594)
        at java.lang.Thread.run(Thread.java:619)
    
    1 回复  |  直到 16 年前
        1
  •  3
  •   skaffman    16 年前

    我想你有很多问题。

    • JBoss正在尝试部署该文件 velocity.log deploy 目录这显然不是您想要的,但要意识到,任何文件都会被放入 部署 目录,JBoss将尝试并部署。你需要找出是什么在做这件事,并阻止它。