代码之家  ›  专栏  ›  技术社区  ›  Sam

phusion乘客发动机模块未启动我的rails应用程序

  •  0
  • Sam  · 技术社区  · 13 年前

    注: 由于我需要部署多个rails应用程序,所以我需要乘客安装nginx模块

    操作系统 ubuntu 12.04 LTS 64位

    红宝石 REE 1.8.7(通过明盒回购安装)

    轨道 2.3.17

    Nginx通过安装 乘客安装发动机控制模块

    乘客 3.0.19

    恩金克斯 1.2.6

    我的nginx.conf

    /opt/nginx/conf/nginx.conf

    #user  nobody;
    worker_processes  1;
    
    #error_log  logs/error.log;
    #error_log  logs/error.log  notice;
    #error_log  logs/error.log  info;
    
    #pid        logs/nginx.pid;
    
    
    events {
        worker_connections  1024;
    }
    
    
    http {
        passenger_root /usr/lib/ruby/gems/1.8/gems/passenger-3.0.19;
        passenger_ruby /usr/bin/ruby1.8;
    
        include       mime.types;
        default_type  application/octet-stream;
    
        #log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
        #                  '$status $body_bytes_sent "$http_referer" '
        #                  '"$http_user_agent" "$http_x_forwarded_for"';
    
        #access_log  logs/access.log  main;
    
        sendfile        on;
        #tcp_nopush     on;
    
        #keepalive_timeout  0;
        keepalive_timeout  65;
    
        #gzip  on;
    
        server {
            listen       80;
            server_name  localhost;
            root   /home/sampath/railsdemoapp/public;
            passenger_enabled on;  
    
    }
    }
    

    当我通过sudo/opt/nginx/sbin/nginx启动nginx时,当我访问url时,它显示403 Forbidden nginx/1.2.6

    1 回复  |  直到 13 年前
        1
  •  1
  •   Hongli    13 年前

    这是因为Nginx是以www数据或其他www用户的身份运行的。必须允许他访问“/home/sampath/railsdemoapp/public”。您需要修复您的权限。