代码之家  ›  专栏  ›  技术社区  ›  Damian Yerrick

为什么CURLOPT_FOLLOWLOCATION与open_basedir不兼容?

  •  1
  • Damian Yerrick  · 技术社区  · 12 年前

    当服务器管理员设置了 open_basedir . 这产生了类似SO的问题 curl follow location error 有很多重复,大多数答案要么是“切换到允许关闭的托管提供商” 打开基本目录 “或 abstraction inversions 试图(以不同的质量级别)在PHP中重新实现cURL的HTTP重定向逻辑。

    我只是想知道为什么PHP开发人员一开始就选择让它们互斥。 当服务器管理员设置了HTTP或HTTPS URI时,PHP拒绝遵循从一个HTTP或HTTPS URL重定向到另一个HTTP和HTTPS URI的策略的安全目的是什么 打开基本目录 提供

    1 回复  |  直到 9 年前
        1
  •  4
  •   mario    12 年前

    它最初的实现是因为 libcurl 没有忽视 Location: file:// 重定向。自从 curl 还允许本地文件访问,这将颠覆basedir约束。

    这种设计上的“不兼容性”在最近的版本中有所松动,顺便说一句: