我已经使用amazonec2插件好几个月了,一切正常。
Unable to load AWS credentials from any provider in the chain: [EnvironmentVariableCredentialsProvider: Unable to load AWS credentials from environment variables (AWS_ACCESS_KEY_ID (or AWS_ACCESS_KEY) and AWS_SECRET_KEY (or AWS_SECRET_ACCESS_KEY)), SystemPropertiesCredentialsProvider: Unable to load AWS credentials from Java system properties (aws.accessKeyId and aws.secretKey), com.amazonaws.auth.profile.ProfileCredentialsProvider@5c06b89: No AWS profile named 'default', com.amazonaws.auth.EC2ContainerCredentialsProviderWrapper@2f169e09: Unable to load credentials from service endpoint]
有人可能会想,很明显,它无法加载凭据。。。但是,这些凭证很好,因为它们与其他插件使用的凭证相同,并且
它们与此插件的初始配置上使用的凭据相同
,当它使用凭据从AWS获取活动的Spot车队请求列表时。。。我的意思是,插件已经在使用凭据,所以它可以实际加载它们。
那么,是什么导致了这个错误呢?
有关插件的信息,请访问
https://jenkins.io/blog/2016/06/10/save-costs-with-ec2-spot-fleet/